Invalid byte sequence in UTF-8?

Hello everybody, nice to join here.
I’m getting a very hard-to-debug error when launching middleman server on a project

/var/lib/gems/2.3.0/gems/middleman-core-4.2.1/lib/middleman-core/util/data.rb:60:in `match’: invalid byte sequence in UTF-8 (ArgumentError)

I’m trying to adapt a free HTML5 template as a middleman template, files are all encoded in UTF-8 but I didn’t actually write it all so I would need a tool to find these “invalid sequences”…

Any suggestions?

It could be that there is a binary SVG file (such as one from a web font) that causes this. You could remove the offending SVG file or see if this helps you.

I’ve removed every single SVG file in the /source/ folder, Nothing changes! Why is this?
Isn’t there any tool to accomplish this?

In the end I solved this by deleting every single font file (.eot, .woff).

i had this issue. i found this post and looked for svg and font files but had none. so I deleted a csv folder w file that wasnt using from data folder and a few bootstrap template pages that wasn’t using. one of those worked so most likely it was the csv.